Tankanzeige / Verbrauchsmessung (abgeschlossen)

Wer arbeitet gerade an welchem SW/HW Thema...
Antworten
Ingo
Beiträge: 5
Registriert: 17 Jun 2005 - 17:40
Wohnort: Tönisvorst

Tankanzeige / Verbrauchsmessung (abgeschlossen)

Beitrag von Ingo » 17 Jun 2005 - 17:54

Hallo,
habe mich nach dem letzten FAT-Treffen für den SIXO entschieden! Nun warte ich und überlege was man noch verbessern kann.
Ich denke eine Tankanzeige wäre besonders für AT-Fahrer sinnvoll. Ich denke in Verbindung mit einem Durchflussmesser (Possis-Sprittmesser) und dem Tachosignal sollte soetwas doch zu machen sein. Ich denke da an eine Anzeige mit dem aktuellen Tankinhalt in Liter, sobald man tankt sollte man diese zurücksetzen können. Wenn wir einmal dabei sind könnte man direkt eine Verbrauchsanzeige (L/100km) einarbeiten.

Ein anderer Gedanke wäre die Einbindung von Griffheizungen. Ich dachte da an das Ein- und Ausschalten incl. evtl. regeln der Heizleistung. Dann würde der originale häßliche Schalter wegfallen!

:)

Wäre super wenn soetwas alles gehen würde!!

Gruß
Ingo

MarkusK
Beiträge: 4
Registriert: 30 Mai 2005 - 10:02
Wohnort: Oldenburg (Oldb.)

Beitrag von MarkusK » 02 Jul 2005 - 15:19

Hallo Ingo,

auch ich hatte Interesse an einem Spritmesser für die AT und habe mir auch schon ein paar konkrete Gedanken darüber gemacht. Jetzt habe ich mir vor kurzem den SIxO bestellt (Lieferzeit wohl ca. 2 Monate) und werde mich mit meinem Kumpel gleich nach Erhalt mal an diese Problematik begeben. Vielleicht haben wir bis Mitte Oktober schon konkrete Ergebnisse.

Schöne Grüße

MarkusK aus Oldb. (Oldb.)

Ingo
Beiträge: 5
Registriert: 17 Jun 2005 - 17:40
Wohnort: Tönisvorst

Beitrag von Ingo » 03 Jul 2005 - 16:50

Hallo Markus,

hast du und dein Freund elektrotechnische Kenntnisse, sowie Erfahrung beim Programmieren?

Ich leider nicht! Da das SIXO-System jedoch "offen" ist habe ich schon darüber nachgedacht mir die Programmierkenntnisse an zu eignen.

Zur Zeit messe ich den Kraftstoffverbrauch mit Possis Sprittmesser!

Naja, dann werden wir beide wohl noch 2 Monate warten müssen. Kann es kaum noch erwarten. Habe mir schon VDO Sensoren gekauft und werde die Wartezeit damit überbrücken bereits meine AT auf den SIXO vorzubereiten! :D

Gruß Ingo

MarkusK
Beiträge: 4
Registriert: 30 Mai 2005 - 10:02
Wohnort: Oldenburg (Oldb.)

Beitrag von MarkusK » 04 Jul 2005 - 07:33

Hallo Ingo,

Kenntnisse sind vorhanden! Ich weiß, hier haben sich die Implementierung des Spritmessers schon einige vorgenommen und es ist noch nicht viel draus geworden ... zur Zeit bin ich noch optimistisch :wink:

Nichts desto trotz, ist es nie ganz weg, wenn man Programmierkenntnisse hat oder jemanden mit welchen kennt :D

Wünsche und Anregungen bezogen auf den Spritmesser werden noch entgegen genommen!


Gruß MarkusK aus Oldb.

RenéAT
Beiträge: 1
Registriert: 03 Sep 2005 - 10:34

Beitrag von RenéAT » 03 Sep 2005 - 10:52

Hallo,

Ich hab schon vor einiger Zeit mal das Selbe bei den Entwicklern angeregt.
Die Messturbine währe erst mal kein Problem, die gibts recht günstig bei der Firma Digimesa bzw im Conrad Katalog und wird auch bei der Spritmesserschaltung vom Endurostammtisch Straubing verwendet.
Das Teil hat eine höhere Genauigkeit als Possie's Messturbine, ist billiger und hat nochdazu einen open Collector Ausgang, liefert also schon ein fix und fertiges Rechtecksignal und währe problemlos an einem Eingang des SIXO anzuschliessen.

Das Problem ist, dass das Rechtecksignal mit einer zu hohen Frequenz ankommt als dass Polling in Frage kommen würde (so gehen einige Impulse verloren und die Messung stimmt nicht mehr)
Man müsste die Messturbine also an einen Eingang hängen der ähnlich dem des Radsensors funktioniert, und ein solcher steht wol nicht mehr zur Verfügung.

Als Alternative ist mir aber bei der Lektüre des Conrad Kataloges einige Drucksensoren ins Auge gefallen. Mit einem solchen an einem analogen Eingang des SIXO könnte man den hydrostatischen Druck im Tank erfassen und so auf den Tankinhalt Rückrechnen.
Das hätte ausserdem den Vorteil dass man nach dem Tanken nicht rücksetzten muss und man auch den richtigen Inhalt angezeigt bekommt wenn nicht voll getankt wird.
Problem: Ich weiss nicht ob die Dinger Benzinresistent sind und ob sie sensibel genug sind um die doch sehr kleinen Druckänderungen genau genug zu erfassen.
Ausserdem bleibt anzuzweifeln ob das bei schwappendem Tankinhalt noch funktioniert.
Wenn sowas nur im Stillstand brauchbare Werte liefert macht es keinen Sinn.

Was die Heizgriffe angeht so hat der SIXO ja noch freie Ausgänge.
Die muss man nur noch Leistungsfest machen (MOSFET's oder elektronische Relais) dann würde auch einer Temperatursteuerung (z.B. per Pulsbreitensteuerung) nix mehr im Weg stehen.
Das Ganze dann noch z.B mit nem Balken oder ner Zahl von 0 bis 10 im Display angezeigt sollte schon machbar sein.

HzG, René

Ansgar
Beiträge: 177
Registriert: 03 Mär 2004 - 16:36
Wohnort: München
Kontaktdaten:

Beitrag von Ansgar » 09 Sep 2005 - 13:13

Hallo,
ansich hat der M16C ja auch Counter die man verwenden könnte um den Durfluss-Sensor auszuwerten. Allerdings habe ich nicht ins Schaltbild geschaut ob die zur verfügung stehenden Eingänge auch auf einen Counter gesetzt werden können. Wenn ja, dann mus hier keiner Pollen.

Nur habe ich defintiv keine Zeit mehr um mich näher mit der Thematik zu beschäftigen. Leider weil mein Brötchengeber sehr viel Zeit von mir haben.

Gruß Ansgar
SIxO 2.0 / 006 (macht immer Spaß ;-) )

Ralf
Beiträge: 564
Registriert: 20 Feb 2004 - 11:27
Wohnort: Hannover

Beitrag von Ralf » 28 Jan 2012 - 14:40

Habe nur das o.a. Thema Heizgriffsteuerung / Griffheizung hier mal rausgenommen und verlagert nach:
http://www.thiguten.de/sixo-forum/viewtopic.php?p=1703

Der Thread "Verbrauchsmessung" geht hier weiter...
Ralf
Zuletzt geändert von Ralf am 06 Apr 2013 - 08:43, insgesamt 1-mal geändert.

Ralf
Beiträge: 564
Registriert: 20 Feb 2004 - 11:27
Wohnort: Hannover

Beitrag von Ralf » 28 Jan 2012 - 15:24

Inspiriert und gepushed durch Chris und die Wunschliste habe ich das Thema mal erneut zum Leben erweckt:

Chris hat einen geeigneten Durchflussgeber gefunden, der vom Material & elektr. Anschlüssen her sehr gut für den SIxO geeignet ist

Mit nur 3 Anschlüssen (12V, GND, Impuls) und einem sauberen Rechtecksignal ist der Adaptionsaufwand für den SIxO minimal. Einige User haben den Geber bereits am Motorrad im Einsatz und offensichtlich gute Erfahrungen gemacht.

Relaisierungsvorschlag:
- Anschluss: Impulsgeber an SIxO-GPI
- Auswertung: GPI zusätzlich per Interrupt samplen (Interrupts zählen)
- Adaption: Im Einstellungs-Instrument "Impulse/Liter" einstellen
- Verbrauchanzeige: Im Haupt-Instrument (wo jetzt schon die "Tank-km" stehen)
- Reset: wie bisher durch langes [Ok] bei Tankanzeige (stellt den Impulszähler auf 0)
- Warnung: Im Einstellungs-Instrument "Verbrauchswarnung bei xx.y l."" einstellen

Anzeige/Auswertung/Bedienung müsste man noch mal genau durchdenken. Im Moment steht eh die Heizgriffsteuerungan - danach geht's mit dem Durchflussgeber weiter.

Ralf

Sully
Beiträge: 64
Registriert: 26 Jan 2006 - 09:48
Wohnort: Peine
Kontaktdaten:

Beitrag von Sully » 11 Apr 2012 - 18:28

Kann man schon Kabel verlegen für den Durchflussgeber? Habe die Maschine gerade komplett abgestrippt. Von daher würde es sich ja anbieten.

.... es sei denn es dauert wieder ein paar Jahre bis es weiter geht. Bis dahin habe ich dann schon wieder eine neue Maschine und eine heute evtl. durchgeführte Kabel verleg Aktion, macht bis dahin nicht mehr so wirklich viel Sinn.
:roll: :roll: :roll:
so long .. Sully

<img src="http://www.vforce700.de/bilder/sixo3.jpg">
SixO 2.0 #71 - Blaue HG Beleuchtung - Seit 07/12 mit weißer HG Beleuchtung

klesk
Beiträge: 38
Registriert: 22 Mär 2011 - 10:58
Wohnort: Dietersheim (Eching)

Beitrag von klesk » 11 Apr 2012 - 18:43

das soll im nächsten update kommen;-) ralf is dran...

Ralf
Beiträge: 564
Registriert: 20 Feb 2004 - 11:27
Wohnort: Hannover

Beitrag von Ralf » 11 Apr 2012 - 22:28

Kann man schon Kabel verlegen für den Durchflussgeber?
Ach - Kabel kann man nie genug haben, wer weiß, was noch alles kommt... :wink:

klesk
Beiträge: 38
Registriert: 22 Mär 2011 - 10:58
Wohnort: Dietersheim (Eching)

Beitrag von klesk » 06 Mai 2012 - 20:23

ralf die kabel liegen... ;-)
wie schauts bei dir aus?

Ralf
Beiträge: 564
Registriert: 20 Feb 2004 - 11:27
Wohnort: Hannover

Beitrag von Ralf » 06 Jun 2012 - 22:01

Die erste Version mit Auswertung des Tanksensorsignals liegt vor:
http://www.thiguten.de/sixo-forum/viewtopic.php?t=300

Eine weitere Version - mit vollständiger Auswertung - folgt demnächst.

Ralf

Sully
Beiträge: 64
Registriert: 26 Jan 2006 - 09:48
Wohnort: Peine
Kontaktdaten:

Beitrag von Sully » 12 Jun 2012 - 17:12

Ich hätte bei der Gelegenheit gleich mal eine Frage zu dem Durchflussmesser.

Der hier beschriebene Durchflussgeber 150391 ist lt. Conrad Homepage erst wieder ab dem 27.7.2012 lieferbar. Beim betrachten der Datenblätter fällt auf, das dieses Modell ohnehin etwas kurze Anschlüsse (7,4 mm je Seite ohne "Kragen") für die Benzinleitung hat.

Das Modell 150392 ist A) lieferbar hat B) auch etwas längere Anschlüsse (8,6 mm je Seite) und ist C) sogar minimal günstiger.

Allerdings hat das Modell 150392 eine andere Impulszahl

( http://www.conrad.de/ce/de/product/1503 ... Detail=005 )

Spricht etwas gegen das Modell 150392? Wird das Teil, egal ob Typ ... 391 oder ... Typ 392, eigentlich mit oder ohne Düse verbaut? Danke für die Rückmeldung.
so long .. Sully

<img src="http://www.vforce700.de/bilder/sixo3.jpg">
SixO 2.0 #71 - Blaue HG Beleuchtung - Seit 07/12 mit weißer HG Beleuchtung

Peter
Beiträge: 91
Registriert: 03 Mär 2004 - 19:37
Wohnort: Solingen
Kontaktdaten:

Beitrag von Peter » 14 Jun 2012 - 09:14

Sully hat geschrieben:Beim betrachten der Datenblätter fällt auf, das dieses Modell ohnehin etwas kurze Anschlüsse (7,4 mm je Seite ohne "Kragen") für die Benzinleitung hat.

Das Modell 150392 ist A) lieferbar hat B) auch etwas längere Anschlüsse (8,6 mm je Seite) und ist C) sogar minimal günstiger.

Allerdings hat das Modell 150392 eine andere Impulszahl
Hallo,
man kann ja in einer Dreherei einfach 2 Adapter mit G1/8" Gewinde für den Benzinschlauch anfertigen lassen, ist ja kein richtiger Aufwand.

Eine geänderte Impulszahl macht bestimmt eine Softwareanpassung notwendig.

Ich werde das jedenfalls so machen wenn der Geber lieferbar ist.
Gruß aus Oberbayern

Peter

SIxO 2.0 / 005

Ralf
Beiträge: 564
Registriert: 20 Feb 2004 - 11:27
Wohnort: Hannover

Beitrag von Ralf » 14 Jun 2012 - 14:41

Sully hat geschrieben:Das Modell 150392 ist A) lieferbar hat B) auch etwas längere Anschlüsse (8,6 mm je Seite) und ist C) sogar minimal günstiger. Allerdings hat das Modell 150392 eine andere Impulszahl
Ein anderer Sensor ist kein Problem, solange er ein 12V Impuls (Rechteck/Sinus) liefert! :-)

Die real verwendete Impulsrate kann im Gerät im Einstellungsmenü 'Erweiterungen' angepasst werden, 0..64000 Impulse/Liter werden (zumindest von der Software) unterstützt. Allerdings darf sich der Propeller nicht zu schnell drehen (z.B. beim 'Reinpusten'), weil die Hardware dann mit dem Eingangsfilter nicht hinterherkommt. Aber für Flüssigkeiten, die real durch die kleine Düse vorbeifließen reicht es alle mal.

Über diesen Einstellwert kann der Impulsgeber auch feinkalibriert werden, falls die gemessene Menge nicht der realen Menge entspricht.
Sully hat geschrieben:Typ 392, eigentlich mit oder ohne Düse verbaut?
Die Düse beeinflusst (neben der max. Duchflussmenge!) die Impulsrate, das kann aber über den Einstellwert kompensiert werden. Beim nächsten Tanken siehst du dann schon an den Messwerten, um wie viel die Messung daneben lag.

Was die mech. Anschlüsse angeht, da sind der eigenen Fantasie keine Grenzen gesetzt....

Ralf

Ralf
Beiträge: 564
Registriert: 20 Feb 2004 - 11:27
Wohnort: Hannover

Beitrag von Ralf » 17 Jun 2012 - 14:00

Es taucht immer wieder die Frage nach geeigneten Durchflusssensoren auf.
Chris, Sully und Peter haben bereits recherchiert, vielen Dank!
Ich versuche das hier mal zusammenfassen:

Typischer Anwendungsfall:
Zwei vereinfachte Überschlagsrechnungen:
- Stadtverkehr (Stop&Go): 5 L/100km, durch. 30 km/h => 0,025 L/Min
- Autobahn (Vollgas): 10 L/100km, durch. 200 km/h => 0,333 L/Min

Elektrische Anforderungen für SIxO:
- Versorgungsspannung: idealerweise 12V (viele haben 5..24V)
- Signalausgang: 12V, Rechteck (oft durch int./ext. PullUp-Widerstand)
- Impulsrate: ~1000..64000 Impulse/Liter (im SIxO einstellbar)
- Impulsfrequenz: max. ~100/sek. (vom SIxO zu verarbeiten, abh. von realer Durchflussmenge)

Mechanische Anforderungen an Sensor
- möglichst große Düse (kein Benzinmangel bei lange Vollgasfahrt)
- möglichst kleine Düse (gute Sensorwerte bei geringem Durchfluss)
- Anschluss: erlaubt direkt Benzinschlauch
- Betriebstemperatur: -20..+80 °C (Automotive)
- Material: Benzinfest (z.B. POM - Polyoxymethylen)

Sensor-Kennlinie (Imp./L über L/Min)
- Kennlinie im gesamten Bereich möglichst linear (geringe Gesamtfehler)
- hohe Auflösung (Imp./Liter hoch => genauer Momentanverbrauch)
- möglichst niedrige minimale Durchflussmenge (0,01 .. 1,0 L/Min)
Hier zwei Beispielkennlinien bei 1,6 mm Düse und bei 1,0 mm Düse.

Auswahl an Sensoren (Stand 6/2012)
Hier eine Auswahl in Frage kommender Sensoren & Links zu Datenblättern:
- BIOTECH: Biotech 97478039
- Conrad: Biotech 150391
- Conrad: Biotech 150392
- BIOTECH: Biotech 97478366
- BIOTECH: Biotech 97478844

Bild


Wer Alternativen zu Biotech kennt, bitte hier eintragen. Bei Biotech sind übrigens nicht alle Datenblätter online zu finden. Elektrisch & vom Material her sind alle o.a. Sensoren ok. Aber keiner der Sensoren ist perfekt für den SIxO geeignet. Benutzen kann man sie aber schon - Chris fährt z.Bsp. schon längst mit dem 15039 zufrieden herum.

Bye, Ralf
Zuletzt geändert von Ralf am 29 Jun 2012 - 18:48, insgesamt 7-mal geändert.

Sully
Beiträge: 64
Registriert: 26 Jan 2006 - 09:48
Wohnort: Peine
Kontaktdaten:

Beitrag von Sully » 17 Jun 2012 - 21:20

Habe heute das RC in den Sixo eingespielt und mich ein bisschen mit den neuen Menüs beschäftigt.

Mir stellt sich nun die Frage, ob man bei der Pulszahl/pro Liter nicht eine Kalibrierfunktion hätte einbauen können.

Aktuell ist es ja so, das man den ca. Impulswert/pro Liter aus dem Datenblatt in den Sixo eingeben muss.

Hätte man stattdessen nicht vielleicht eine Kalibrierfunktion einbauen können. Soll heißen, man läßt definiert einen Liter Flüssigkeit durch den Durchflussmesser laufen und der Sixo zählt dabei die Impulse.

Die so ermittelten Impulse werden dann als realer Ist Wert pro Liter im Setup Menü des Sixo übernommen.

Nur so als Idee für die Final Version :wink:
so long .. Sully

<img src="http://www.vforce700.de/bilder/sixo3.jpg">
SixO 2.0 #71 - Blaue HG Beleuchtung - Seit 07/12 mit weißer HG Beleuchtung

Sully
Beiträge: 64
Registriert: 26 Jan 2006 - 09:48
Wohnort: Peine
Kontaktdaten:

Beitrag von Sully » 24 Jun 2012 - 08:45

So. dann will ich mal berichten:

Ich habe gestern den Durchflussmesser vom Typ 150392 verbaut. Wegen der "besseren" Messergebnisse gesah dieses mit der 1,6 mm Düse = 8500 Pulse/pro Liter

Als Widerstand kam ein 2,2kOhm Widerstand zum Einsatz.

Der Einbau als solches bereitete keine Schwierigkeiten. Die Anschlüsse für den Benzinschlauch sind beim Typ 150392 vollkommen ausreichend. Die Schläuche sitzen schön fest drauf und können mit den Serienmäßigen Befestigungsklemmen gegen herunter rutschen fixiert werden.

Das war schonmal einfach :-) Also - alles angeschlossen und mal in den Durchflussmesser reingeblasen - Juhu, der Sixo zeigt was an - somit wohl alles richtig gemacht.

Kommen wir jetzt zur Probefahrt:

Als erstes muss ich mal anmerken, das ich ein wenig verwirrt war, was das Setup Menü betrifft.

Man kann ja hinter dem Menüpunkt mit dem Tankinhalt, einen selbst errechneten Durchschittsverbrauch in L/h eingeben. Das wird wohl dafür sein, wenn man keinen Durchflussmesser hat. Diesen L/h Wert, findet man dann aber im Tacho Bild als Durchschnittsverbrauch pro 100 km wieder.

Ich denke es muss im Setup Menü auch L/100km heißen, denn so wie ich heraus gefunden habe, wird der dort eingetragene Wert zur Berechnung der verbleibenden Rest Strecke verwendet. Also ein Schreibfehler im Setup Menü.

OK, da bei mir aber der Durchflussmesser verbaut ist, habe ich bei diesem Wert nichts (0) eingetragen.

Nun habe ich das Tachobild mit dem Momentanverbrauch (L/h und D=L/100km) aufgemacht. Motor angelassen und - oh Schreck - keine Anzeige beim Momentanverbrauch. Im Leerlauf mehr Gas gegeben - hmm immer noch kein Verbrauch.

Nanu, beim durchblasen ging doch alles ?!?!?! Also habe ich, von der Verkabelung bis hin zum mechanischen Anschluss des Durchflussmesser alles nochmal kontrolliert - alles OK.

Wieder Motor angeworfen - immer noch nix. Na gut machen wir mal eine Probefahrt und siehe da, plötzlich tauchten vereinzelt Werte bei L/h auf.

Im Stand an der Ampel oder bei Geschwindigkeiten um die 30 km/h steht diese Anzeige aber auf Null. Muss ich wohl ein sehr Energieeffizientes Fahrzeug haben :roll: :lol: :roll: :lol: Erst bei höheren Geschwindigkeiten bekomme ich dort etwas angezeigt.

Die Werte die sich dann dort präsentieren, sind leider nicht fließend. Sie springen von 0 nach 5 nach 10 nach 6,6 nach 3,3 nach 0.

Das sind alle Werte, die ich im Rahmen einer 60 km Testfahrt angezeigt bekommen habe. Ich finde die Aussagekraft dieses Stundenverbrauchs, ist nicht so wirklich der Hammer und verwirrd (ist meine Benzinleitung undicht) mehr als das sie informieren.

Mir persönlich wäre es lieber, wenn ich sehen könnte, was ich aktuell verbrauche. Also eine Anzeige Liter pro Minute oder meinetwegen auch Milliliter pro Minute.

Schade auch, das der Benzinverbrauch im Stand (z.B. an der Ampel) scheinbar so gering ist, das dort zumindest im SixO gar nichts angezeigt wird. Eigentlich müsste bei 8500 Pulsen pro Liter doch auch im Stand ein Durchfluss registriert werden - oder?

Oder liegt das auch an der Darstelung des Verbrauchs pro Stunde?

Ansonsten muss ich mal eine komplette Tankfüllung durchjagen, denn das was der SixO gestern im Rahmen meiner Testfahrt ermittelt hat, entspricht nicht dem realen Verbrauch der Maschine. Üblicherweise liegt mein Durchschnittsverbrauch bei 9,9 L/100km. Der Sixo Wert der 60 km Testfahrt betrug zum Schluss 6,6 L/100km.

Da ich gestern bei der Testfahrt verhältnissmäßig viel Landstraße mit hohen Vollgasanteil gefahren bin, ist für die Testfahrt ein Verbrauch von 11 Litern/100Km durchaus denkbar.

Rechne ich die 6,6 Liter jetzt auf 100 km hoch, komme ich auf eben diese 11 Liter. Ist da im Sixo evtl. ein Darstellungs- / Rechenfehler denkbar was den Durchschnittsverbrauch auf 100 km angeht?

Wird dieser Durchschnittswert eigentlich für IMMER gespeichert oder ist er nur auf den Inhalt der jeweiligen Tankfüllung bezogen?

Erfreulich ist auf jeden Fall, das alles soweit funktioniert und das ich unter Verwendung der 1,6 mm Düse problemlos Vollgas fahren kann - also kein Ruckeln oder stottern.

So, das war mein kleiner Testbericht mit der neuen Durchflussgeber Funktion am SixO.


Bild
so long .. Sully

<img src="http://www.vforce700.de/bilder/sixo3.jpg">
SixO 2.0 #71 - Blaue HG Beleuchtung - Seit 07/12 mit weißer HG Beleuchtung

Ralf
Beiträge: 564
Registriert: 20 Feb 2004 - 11:27
Wohnort: Hannover

Beitrag von Ralf » 24 Jun 2012 - 16:22

Hi Sully, vielen Dank für deinen ersten Erfahrungsbericht als BETA-Tester!

Ich hoffe, du hast die Version V3.0.9b eingespielt? In V3.0.9 war noch ein Bug (siehe Mails).

Eine Kalibrierfunktion wäre definitiv komfortabler, Software-Aufwand und Übertragbarkeit auf den realen Betrieb (Durchflussgeschwindigkeit & Einbaulage) sprechen im Moment dagegen. Aber du kannst ja auch so mal den Sprit (mehrfach) durchlaufen lassen, der SIxO zeigt die Menge an und du kannst korrigieren.

Der im FZG-Menü einzugebene Durchschittsverbrauch (natürlich in l/100km) wird für Berechnungen des realen Durchflussmessers nicht verwendet, er wird nur solange angezeigt, bis erste reale Messwerte vorliegen. Die Maßeinheit werde ich aber noch verbessern. Wenn kein Durchflusssensor verbaut ist, dient er als alleinige Berechnungsgrundlage (so dass alle was davon haben).

Der Momentanverbrauch war eigentlich nur als Zusatzfeature zum viel wichtigeren Durchschnittsverbrauch und Reichweiten gedacht. Systembedingt kommt man bei dem kurzen Zeitintervall des Momentverbrauchs an die Auflösungsgrenze der Eingangswerte. Grundsätzlich funktioniert der Momentanverbrauch, aber es gibt - gerade bei geringen Durchflussmengen - viele Fehlerquellen (siehe o.a. Kennlinien). Ich werde den Messintervall noch erweitern und auch an meiner BMW testen. Wenn die Messung nicht taugt, schmeiße ich den Momentanverbrauch wieder raus.

Im Vordergrund stand immer die Frage: "Wie weit komme ich jetzt wirklich noch?". Durch die große Spritmenge/Impulszahl und Strecke wird der daraus berechnete Durchschnittsverbrauch relativ genau. Für mich ist deswegen erst mal die Frage wichtig: Wenn der Impulsgeber richtig kalibriert ist, wie stark schwanken dann noch die Abweichungen zwischen Anzeige 'SIxO-Verbrauchte Liter' und Tanksäule 'getankte-Liter"?. D.h, wie gut reproduziert der SIxO die Benzinmenge unter realen Bedingungen, oder: Wie verlässlich ist er? :-)

Es wäre also schön, wenn du mal ein paar Tankintervalle beobachten würdest (evtl. nachkalibrieren), ich bin gespannt auf deine Ergebnisse...

Ralf

Ralf
Beiträge: 564
Registriert: 20 Feb 2004 - 11:27
Wohnort: Hannover

Beitrag von Ralf » 29 Jun 2012 - 18:51

Habe die o.a. Tanksensor-Vergleichsliste mal geupdated!

Ralf

klesk
Beiträge: 38
Registriert: 22 Mär 2011 - 10:58
Wohnort: Dietersheim (Eching)

Beitrag von klesk » 01 Jul 2012 - 18:43

sooo dann schreib ich auch ma was:
8000 km in den letzten 3 wochen mit dem sensor.
beim reisen passt der wert fast immer, sixo zeigt zwischen 0 und 0,5 l mehr an als verbraucht wurde (in die richtung is es für mich ok so und bleibt).
auf der autobahn zeigt er aber mit dem gleichen einstellwert auf 20 liter gleich ma 1,5 liter zu wenig... die ganze sache is wohl hardwarebedingt aber ich habs auch noch nich wegbekommen, wenn ich ihn auf der bab neu einrichte dann passts überland nichmehr und andersrum hatte ichs ja.
bei mir bleibt er jetzt auf überland eingestellt da ich das eh zum großteil fahre und die bab nur ne notlösung ist.
im gelände funzt der sensor auch absolut zuverlässig.

die anzeige des aktuellen verbrauchs ist wie beim vorschreiber recht "sprunghaft" aber nich weiter störend, beim beschleunigen passts ganz gut und beim touren hab ich die anzeige nicht an...

gruß chris

KTMil
Beiträge: 5
Registriert: 18 Apr 2010 - 17:22
Wohnort: G-Town

Beitrag von KTMil » 04 Jul 2012 - 08:21

Spannende Sache! Ich wollte meinen Sixo auch um den Durchflussmesser erweitern, habe aber ein paar Fragen:

- Wo gibts die Firmware 3.09b zum Download? Ich habe auf Sourceforge nur die 3.06 gefunden ...
- Wenn ich mir die Datenblaetter so anschaue, kaeme fuer mich am ehesten der 150392 in Frage mit der 1mm Duese. Bei Conrad finde ich den nur mit 1,6 mm Duese - wo habt ihr die kleinere Duese her?
- Widerstand 2,2kO? Was fuer ein Widerstand und wo kommt der hin?
SIxO 2.0

KTMil
Beiträge: 5
Registriert: 18 Apr 2010 - 17:22
Wohnort: G-Town

Beitrag von KTMil » 04 Jul 2012 - 08:22

Noch eine Idee: dass die Anzeige des Momentanverbrauchs sprunghaft ist, ist klar - koennte man da nicht ueber einen geeigneten Zeitraum mitteln, z.B. ueber 20 Sekunden?
SIxO 2.0

klesk
Beiträge: 38
Registriert: 22 Mär 2011 - 10:58
Wohnort: Dietersheim (Eching)

Beitrag von klesk » 04 Jul 2012 - 13:19

ich hab den sensor mit 1/8 anschluss und dann 1/8 auf 6mm schlauch adapter aus messing... die haltens auch aus wenn du die schlauchschelle fester anknallst...
@all, ich hab den widerstand eingelötet wie er im datenblatt stand... bringt ein größerer widerstand eventuell bessere messwerte? bin zwar der meinung dass es nix bringt aber ma doof fragen kann man ja;-)

gruß chris

Sully
Beiträge: 64
Registriert: 26 Jan 2006 - 09:48
Wohnort: Peine
Kontaktdaten:

Beitrag von Sully » 04 Jul 2012 - 17:20

Bin bei dem Mistwetter der letzten Tage noch nicht viel zum fahren gekommen.

Von daher kann ich leider noch keine weiteren Angaben machen.

Da es aber weiterhin so aussieht, als wenn die verbrauchte Menge die der Sixo anzeigt und die zu erwartende Nachtankmenge nicht überein stimmen werden, habe ich schonmal bei BioTech angefragt, was die 1 mm Düse kostet.

Ich denke nur so wird man die Messauflösung verbessern können (mehr Pulse pro Liter)

Die Antwort von BioTech ist - 2,10 Euro pro Düse zzgl. MwSt. + Versand. Man kann im übrigen nicht nur die Standart Düsen bekommen sondern jede beliebige mit 1/10 Staffelung.

Also 1,0; 1,1,; 1,2; 1.3 usw.

Aber vielleicht braucht man das gar nicht, wenn man ggf. über den Dreisatz die Pulszahl anpassen kann und diese Anpassung dann auch zu einem vernünftigen Ergebniss führt.

Beispiel: Sixo Anzeige 6,8 Liter bei 8500 Pulsen (1,6 Düse) pro Liter
Real nachgetankt: 9,3 Liter

Macht also 8500/9,3=913,9784946236559
913,9784946236559*6,8=6215 Pulse als neuer Pulse / pro Liter Wert.

Ich vermute mal, das die Anzahl der Pulse pro Liter sehr von der Einbaulage und auch von der Temperatur abhängig ist.

Ein Durchflussmesser in Motor nähe, wird evtl. mit steigender Betriebstemperatur einen anderen Korrekturfaktor benötigen als im kalten Zustand. Vielleicht sind die Abweichungen im Winterbetrieb sogar noch gravierender. :roll:

Achso im übrigen: Der Durchschnittliche Verbrauch auf 100km bleibt auch beim resetten der Tankanzeige erhalten. Somit bekommt man quasi einen Lebenzeit Durchschnittswert.

Das halte ich persönlich für nicht so geeignet, da sich die Fahrbedingungen ja ändern (Offroad, Onroad, Leistungssteigerung am Motor usw.)

Klar bekomme ich über den Verbrauch die Rest Kilometer der aktuellen Tankfüllung angezeigt. Aber am Ende dieser Tankfüllung wüßte ICH schon gerne wie hoch mein Liter/100km Verbrauch mit dieser Tankfüllung war.

Also ich konnte zumindest den berechneten Durchschnittsverbrauch nicht wieder zurück stellen.
Zuletzt geändert von Sully am 04 Jul 2012 - 18:57, insgesamt 1-mal geändert.
so long .. Sully

<img src="http://www.vforce700.de/bilder/sixo3.jpg">
SixO 2.0 #71 - Blaue HG Beleuchtung - Seit 07/12 mit weißer HG Beleuchtung

klesk
Beiträge: 38
Registriert: 22 Mär 2011 - 10:58
Wohnort: Dietersheim (Eching)

Beitrag von klesk » 04 Jul 2012 - 18:26

hi sully,

also das mit dem dreisatz passt super... so hab ichs gemacht und bin recht genau dran bei ner 1mm düse.

gruß chris

Ralf
Beiträge: 564
Registriert: 20 Feb 2004 - 11:27
Wohnort: Hannover

Beitrag von Ralf » 04 Jul 2012 - 21:20

Super - so viel Feedback, das ist wichtig, danke!
KTMil hat geschrieben:Wo gibts die Firmware 3.09b zum Download? Ich habe auf Sourceforge nur die 3.06 gefunden ...
Die habe ich erstmal an die 'registrierten Betatester' 8) per Mail gesendet, weil sie noch nicht so richtig dufte ist. Wenn du auch testen willst/kannst, sende mir ne PN.
KTMil hat geschrieben:Bei Conrad finde ich den nur mit 1,6 mm Duese - wo habt ihr die kleinere Duese her?
BIOTECH verkauft alles auch selbst, habe mir dort gerade den 97478366 bestellt. UPS-Versand schlägt etwas stark drauf, ist für mich aber ok. (50 € Summe)
KTMil hat geschrieben:Widerstand 2,2kO? Was fuer ein Widerstand und wo kommt der hin?
Ob/wo/wie Pullup - das steht alles in den o.a. Datenblättern.
KTMil hat geschrieben:ueber einen geeigneten Zeitraum mitteln, z.B. ueber 20 Sekunden?
Jepp - das ist der Trend ;-). Ob 20 Sek. jetzt noch ein "Momentanverbrauch" ist, sei mal dahin gestellt. In der nächsten Version (und an meiner BMW) werde ich das mal verbssern & testen.
klesk hat geschrieben:bringt ein größerer widerstand eventuell bessere messwerte?
Der Widerstand verhält sich wie die SIxO-internen Widerstände an den GPIOs: Er versucht, einen sauberen rechteckigen Signalverlauf sicherzustellen. An der Sensor-Kennlinie (siehe oben) und damit an den Messwerten ändert der gar nichts. Die empfohlene 2k sind schon ok.
Sully hat geschrieben:Da es aber weiterhin so aussieht, als wenn die verbrauchte Menge die der Sixo anzeigt und die zu erwartende Nachtankmenge nicht überein stimmen werden, habe ich schonmal bei BioTech angefragt, was die 1 mm Düse kostet. Ich denke nur so wird man die Messauflösung verbessern können (mehr Pulse pro Liter)
Mit der kleinen Düse wird das sensorinterne Schaufelrad besser (feinerer schnellerer Strahl) angespült. Deshalb ändert sich auch die Kennlinie (und damit auch Impulse/Liter) und das Ansprechverhalten (unterer, nicht linearer Kennlinienbereich). Tendenziell ist die kleinere Düse immer besser, weil die Losbrechkraft und Empfindlichkeit bei kleinen Durchflussmengen besser ist.

Aber irgendwann kommt man auch an die Grenze, wenn bei Vollgas nicht mehr genug Sprit durch die Düse kommt. Schlimmstenfalls merkt man das gar nicht und fährt lange Strecken zu mager, der Motor wird heißer und die Gefahr eines Motorschadens steigt! Also ich wäre da vorsichtig...

Die Datenblattangaben zu "Impulse/Liter" sind bei BIOTECH unter Laborbedingungen entstanden (teilw. sogar unter Druck!). Ihr müsst in jedem Fall an eurem Motorrad unter realen Bedingungen nachkalibrieren, ein einfacher Dreisatz (wie o.a.) tut's schon.

Wenn's danach immer noch nicht stimmt, liegt es wahrscheinlich am unteren - nicht linearen Kennlinienbereich (Standgas/Stadtfahrt/Ampeln/niedrige Geschwindigkeit). In diesem Bereich arbeitet der Sensor mit anderen Werten "Impulse/Liter" (und bei zu geringen Mengen garnicht). Das ist aber per Software nur sehr aufwändig zu kompensieren. Wir müssen erstmal Erfahrungen dazu sammeln. Klesks' Ansatz, den Kalibrierwert auf seinen 'Lieblingsanwendungsbereich' (Stadt/Land/Fluss) einzustellen, finde ich schon ganz pragmatisch. ;-)
Sully hat geschrieben:Ich vermute mal, das die Anzahl der Pulse pro Liter sehr von der Einbaulage und auch von der Temperatur abhängig ist.
Lt. Biotech beeiflusst die Einbaulage eher die Entlüftung - nicht die Kennlinie. Waagerecht eingebaut kann es vorkommen, dass eine Blase bestehen bleibt - die natürlich massiv das Strömungsverhalten beeinflusst. Die Temperatur hat weniger Einfluss, es sei denn, sie ist so hoch, dass sich die Viskosität des Benzins verändert ;-).
Sully hat geschrieben:Achso im übrigen: Der Durchschnittliche Verbrauch auf 100km bleibt auch beim resetten der Tankanzeige erhalten. Somit bekommt man quasi einen Lebenzeit Durchschnittswert.
Es wird beim Reset immer der letzte berechnete Durchschnittswert gesichert. Aber das ist eh irrelevant: Beim Fahren mit Tanksensor wird er nicht benutzt, der Durchschnittsverbrauch wird immer auf Basis von Strecke & Durchflussmenge frisch berechnet.

Ich arbeite an dem Thema, sobald ich ein Update für euch habe, melde ich mich.

Ralf

Sully
Beiträge: 64
Registriert: 26 Jan 2006 - 09:48
Wohnort: Peine
Kontaktdaten:

Beitrag von Sully » 05 Jul 2012 - 18:57

Aber irgendwann kommt man auch an die Grenze, wenn bei Vollgas nicht mehr genug Sprit durch die Düse kommt. Schlimmstenfalls merkt man das gar nicht und fährt lange Strecken zu mager, der Motor wird heißer und die Gefahr eines Motorschadens steigt! Also ich wäre da vorsichtig...
Bei (alten/einfachen) Maschinen mit Einspritzung magst du vielleicht recht haben. Ob bei modernen Maschinen mit Lambda Regelung das auch der Fall sein wird, vermag ich nicht zu beurteilen. Könnte mir vorstellen, das solche Maschinen dann vielleicht in ein Notlaufprogramm gehen, wenn der Lambdawert über einen längeren Zeitraum nicht mehr passt.

Bei Maschinen mit Vergaser dürfte dann ggf. irgendwann der Punkt kommen, wo die Schwimmerkammer(n) nicht mehr voll genug sind und die Maschine anfängt zu ruckeln.
so long .. Sully

<img src="http://www.vforce700.de/bilder/sixo3.jpg">
SixO 2.0 #71 - Blaue HG Beleuchtung - Seit 07/12 mit weißer HG Beleuchtung

klesk
Beiträge: 38
Registriert: 22 Mär 2011 - 10:58
Wohnort: Dietersheim (Eching)

Beitrag von klesk » 05 Jul 2012 - 19:06

naja wenn der ralf demnächst ma zeit hat dann können wir ja bei einspritzern den verbrauch übers einspritzventil messen... ;-)
duuuu raaaaalf... hast du die nächsten wochen schon was vor? :twisted:

gruß chris

Peter
Beiträge: 91
Registriert: 03 Mär 2004 - 19:37
Wohnort: Solingen
Kontaktdaten:

Beitrag von Peter » 10 Jul 2012 - 06:08

So, heute ist der Durchflussmesser (97478844) mit 2 Düsen ( 1,0 und 1,6mm) von Biotech angekommen.
Werde heute oder Morgen mal schauen wie/wo ich ihn am besten an der Twin montieren kann.
Und dann geht das testen los........

Nachtrag: Unsere Dreherei hat gerade Langeweile.....da habe ich dann gleich 5 Düsen eingesteuert.
1,1 - 1,5mm aus POM, damit es mehr zum Testen gibt.
Zuletzt geändert von Peter am 11 Jul 2012 - 05:51, insgesamt 1-mal geändert.
Gruß aus Oberbayern

Peter

SIxO 2.0 / 005

Ralf
Beiträge: 564
Registriert: 20 Feb 2004 - 11:27
Wohnort: Hannover

Beitrag von Ralf » 10 Jul 2012 - 20:41

Und dann geht das testen los........
Super - bin gespannt. Mein Durchflusssensor ist gestern auch angekommen (97478366, 3 mm), mit Düsen 1,6 + 1,0 mm. Werde ihn so schnell wie möglich einbauen. Kabel zum SIxO liegen schon, muss sie nur noch in den DSUB25 löten (graus).

Ralf

Sully
Beiträge: 64
Registriert: 26 Jan 2006 - 09:48
Wohnort: Peine
Kontaktdaten:

Beitrag von Sully » 11 Jul 2012 - 18:06

muss sie nur noch in den DSUB25 löten (graus).
Das ist der Grund, warum ich schon seit Anfang an, diese Sub-D Adapterplatine an der Maschine benutze.

Bild

Sie ist von Wago und passt wunderbar in eine Feuchtraum Abzweigdose. Man nimmt sich einfach ein voll beschaltetes 25 poliges Druckerkabel (so ist zumindest die eine Seite schon maschinell und sicher verlötet), baut in den Deckel der Abzweigdose eine wasserdichte Quetschverschraubung und führt das Druckerkabel hindurch.

Nun lötet man wieder die 25 Adern des Druckerkabel an einen Sub-D Stecker und verbindet diesen mit der Wago Platine innerhalb der Feuchtraumdose.

Über die anderen Eingänge der Feuchtraumdose kann man dann, ebenfalls über wasserdichte Quetschverschraubungen, die jeweiligen (Mess)Leitungen in die Dose ziehen und einfach in die Schneidklemmen der Wago Platine reinstecken.

So kann man relativ schnell alles mögliche nachinstallieren oder bei evtl. Verdrahtungsfehlern die Adern schnell mal tauschen, ohne immer an dem fummeligen Sub-D Stecker herum löten zu müssen.
so long .. Sully

<img src="http://www.vforce700.de/bilder/sixo3.jpg">
SixO 2.0 #71 - Blaue HG Beleuchtung - Seit 07/12 mit weißer HG Beleuchtung

Sully
Beiträge: 64
Registriert: 26 Jan 2006 - 09:48
Wohnort: Peine
Kontaktdaten:

Beitrag von Sully » 24 Jul 2012 - 16:24

So, nachdem das Wetter nun einigermaßen mitspielt, habe ich mal ein bisschen Benzin vernichtet :-D

Nach diversen Dreisatz Anpassungen bin ich nun, statt der im Datenblatt angegebenen 8500 Puls/Liter, bei 5092 Pulsen/Liter gelandet.

Speziell bei reinrassigen Überland Fahrten passt das nahezu auf den "Milliliter" genau. Bei Fahrten mit viel Stadtanteil, driftet der nachgetankte Verbrauch im Vergleich zur SixO Rechnung zwischen 100 - 200 Milliliter ab.

Ich denke aber, das dass trotzdem ein ordentlicher Wert ist, mit dem man schon etwas anfangen kann.

Vielleicht können wir hier ja so eine Art Tabelle machen, damit andere es nicht ganz so schwer haben.

Eine Tabelle, wo Durchflussmessertyp, verwendte Düse und Einbaulage, sowie der in dieser Konfiguartion ermittelte beste Pulse/Liter Wert drin stehen, könnte gerade nach der Erstinstallation einen ungefähren Anhaltspunkt geben.
so long .. Sully

<img src="http://www.vforce700.de/bilder/sixo3.jpg">
SixO 2.0 #71 - Blaue HG Beleuchtung - Seit 07/12 mit weißer HG Beleuchtung

Ralf
Beiträge: 564
Registriert: 20 Feb 2004 - 11:27
Wohnort: Hannover

Beitrag von Ralf » 11 Sep 2012 - 22:41

Speziell bei reinrassigen Überland Fahrten passt das nahezu auf den "Milliliter" genau. Bei Fahrten mit viel Stadtanteil, driftet der nachgetankte Verbrauch im Vergleich zur SixO Rechnung zwischen 100 - 200 Milliliter ab.
Uih - das ist aber verdammt gut. Bei 10..20 L Nachtanken nur 0,1..0,2 L. Abweichung beim kritischen Stadtverkehr! Widerspricht auch etwas den bisherigen Erfahrungen und Erwartungen bei den Kennlinien (im unteren Bereich). Aber wenn's klappt... :-)

An der verbesserten Genauigkeit des 'akt. Verbrauchs' arbeite ich noch...

Ralf
Beiträge: 564
Registriert: 20 Feb 2004 - 11:27
Wohnort: Hannover

Beitrag von Ralf » 15 Apr 2013 - 20:50

Das Thema ist jetzt offiziell in eine Release eingeflossen: V3.1.0.

An meiner BMW konnte ich es leider immer noch nicht testen (Nockenwelle liegt darnieder), aber ich konnte die Fzg-Simulation in der Software erweitern und so testen, dass der Momentanverbrauch jetzt definitiv höher aufgelöst und smoother ist...

Bin gespannt auf euer Feedback.

Ralf

Sully
Beiträge: 64
Registriert: 26 Jan 2006 - 09:48
Wohnort: Peine
Kontaktdaten:

Beitrag von Sully » 17 Apr 2013 - 18:57

Erst einmal DANKE SCHÖN für die neue Version. Werde diese die Tage mal einspielen und ein bisschen testen/vergleichen.

Eine erste Ausfahrt nach dem Winter hat aber schon eine kleine Schwachstelle zu Tage gefördert - den Durchflussmesser von Conrad.

Das Fahrzeug stand fast ein halbes Jahr ohne große Bewegung in der Garage herum. Bei der ersten Ausfahrt 2013 lieferte der Durchflussmesser dann keine Impulse mehr.

Offensichtlich hat das stehende Benzin zum festsetzen des Flügelrades gesorgt.

Also Durchflussmesser ausgebaut, durchgeblasen und gespült. Nun tut er es wieder.

By the way - ich habe mir die Version 3.0 des Handbuchs eben mal komplett durchgelesen. An vielen Stellen findet man diesen Eintrag:

Fehler: Referenz
nicht gefunden
.... und das auch bei Eintragungen die es in der Version 2.1 schon gab.

Ein Formatierungsfehler ?????
so long .. Sully

<img src="http://www.vforce700.de/bilder/sixo3.jpg">
SixO 2.0 #71 - Blaue HG Beleuchtung - Seit 07/12 mit weißer HG Beleuchtung

Sully
Beiträge: 64
Registriert: 26 Jan 2006 - 09:48
Wohnort: Peine
Kontaktdaten:

Re: Tankanzeige / Verbrauchsmessung (abgeschlossen)

Beitrag von Sully » 19 Apr 2013 - 22:47

So, heute habe ich die Version 3.10 eingespielt und auch gleich mal getestet (80km). Also ich muss sagen, das man gegenüber der Version 3.09a gerade bei der l/h und l/100km Anzeige eine ganz deutliche Verbesserung spürt.

Da gibt es nicht mehr diese Sprünge. Die angezeigten Werte wechseln sehr viel sanfter und auch die Werte als solches, reagieren auf geringe Änderungen des Gasgriffs mit durchaus plausiblen Anzeige Änderungen.

Also im Bereich der Tankanzeige ein echter Fortschritt. Schaun wir mal, wie sich das alles auf den realen und den gemessenen Benzinverbrauch auswirkt. Dazu kann ich im Moment noch nichts sagen.
so long .. Sully

<img src="http://www.vforce700.de/bilder/sixo3.jpg">
SixO 2.0 #71 - Blaue HG Beleuchtung - Seit 07/12 mit weißer HG Beleuchtung

Antworten